Symptoms
When creating a new account or setting up a new addon domain, the process takes longer than expected to complete, with no indication as to why.
The following is logged to /usr/local/cpanel/logs/dnsadmin_log
Connection Timed Out
Could not connect to https://203.0.113.2:2087/scripts2/getips_local: Connection Timed Out at /usr/local/cpanel/3rdparty/perl/542/cpanel-lib/cPanel/PublicAPI.pm line 259, <$client_socket> line 6.
Too many arguments for subroutine 'Cpanel::NameServer::Remote::determine_error_type' (got 3; expected 2) at /usr/local/cpanel/Cpanel/NameServer/Remote.pm line 41, <$client_socket> line 6.
...propagated at whostmgr/bin/dnsadmin.pl line 608, <$client_socket> line 6.
Cause
This occurs when the primary cPanel server cannot connect to a DNS Cluster server to synchronize the DNS zone for the new domain during account creation.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-45940. Follow this article to receive an email notification when a solution is published in the product.
Resolution
Ensure firewalls on the primary cPanel server and DNS Cluster servers are configured to accept incoming and outgoing connections from the primary cPanel server and DNS Cluster servers.