Symptoms
Granting access to a ticket in WHM can hang or run very slowly. It will finish after 4-5 minutes. The process logs also show a lsof process checking the SSHD port for several minutes.
/usr/bin/lsof -iTCP:22 -sTCP:LISTEN -n
Cause
RHEL 9 ( includes AlmaLinux 9 and CloudLinux 9 ) servers have a default nr_open ( Open file limit ) value of "1073741816". This high value can cause lsof to iterate close FDs up to the maximum limit. This operation slows down the grant ticket access API or causes it to hang/timeout. The grant ticket access API is calling lsof to check the SSHD port. Granting access to a ticket will check the SSHD port to ensure it is running and confirm the port details.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-50844. Follow this article to receive an email notification when a solution is published in the product.
Resolution
Grant access directly via SSH or the WHM terminal with the command below.
AUTHUSER=root TICKET=TICKETID SERVERNUM=SERVER_TAB_NUMBER /scripts/autorepair authorize
Note: Replace TICKETID with the ticket ID in question. Also, replace SERVER_TAB_NUMBER with the server tab number.